WPViewPDF with C++ Builder XE3

  • Hi,
    Trying to install WPViewPDF3 in C++ Builder XE3 (finally upgraded from 6), when I try to install "WPViewPDF_reg.pas" into a new package I get an error that controls.dcu is not found. When I search the Embaracadeo folder, there is no "controls.dcu" (note: I did look on a friends machine with XE, and there is a controls.dcu file there). What I do find are Data.Bind.Controls.dcu, FMX.Control.dcu, and Vcl.Controls.dcu.

    Can you help me get this installed under XE3?

  • It appears to me that all references to controls, forms, graphics, printers, and dialogs need to have "Vcl." added to them for XE3. I have tried that, but still get an error, just a different one.

    [MSBuild Error] "C:\Users\Public\Documents\RAD Studio\10.0\BPL;\stuff.bpl" is an invalid value for the "OutputFile" parameter of the "DependencyCheck" task. Multiple items cannot be passed into a parameter of type "Microsoft.Build.Framework.ITaskItem". Where stuff is the new package name I was trying to use.


  • I too am having the exact same problem in getting it installed on CBuilder XE3. I followed the directions for creating a new package, adding WpViewPDF_reg.pas, vcl.bpi & vclx.bpi. Set the project options as specified and when I try to build it, I get:

    [DCC Fatal Error] WPViewPDF_reg.pas(22): F1026 File not found: 'WPViewPDF3.dcu'

    Is it really possible to install this on CBuilers XE3?