Problem with REportBuilder/stretch

  • HEllo i am using the new v7 WPTOOLS with Report Builder 15


    Now i saw that my old reports didnt work anymore, if i direct print out the report, the Text isn't stretched.
    If i export to PDF or use the PRintPReview all seems ok


    Whats going wrong?

  • No Report Builder 15 i use for a longer time.
    I just changed WPTools from v6 to v7 (and useing the new wpPDF and wpPDFViewer - but don't think that these are the problem)


    With WPTools 6.10 all worked fined but after change to v7 i got the response that the printed sheet isn't printed well (it is only a part of the page)
    After some investigation i checked that it seems that the "STRETCH" property didn't work as expected.


    BUT ONLY if i print it direct to the printer! (real printer, or XPS Printer, or PDF PRinter - none of them works)
    The Preview and the internal PDF Export works WELL!!


    Where can i look for this problem?

  • Sorry, I was sick.


    Did you set stretch for the parent band? That used to be required. Nothing has been changed on the wptools side, so I wonder why your band is not stretching.


    I tried the latest RB17 demo with Delphi XE to run my demo and reproduce the problem, but unfortunately RB does not work anymore for me. It is trying to start a setup.exe from ProgramData when I try to start the demo now. I don't know what has been changed here.


    Julian

  • Yes i did set stretch for the parent Band - the reports worked well all the time before - the only thing I changed was WPEdit ...


    Now i plan to update ReportBuilder to the actual 17version - and will test it again.


    How should i send you the example - the compiled EXE File?

  • No, a compiled exe does not help.


    I need a small project without dependencies.


    Did you update the WPTools RB units? If yes, do you still have the previous which worked. Please use those.


    The ones for V6 will also work for V7 - only the units WPRTEEdit and WPDefsConsts must be included in the unit and the TWPRTFDataCollection is now TWPRTFDataCollectionBase.


    --


    I tried to reproduce the problem but it works alright. I send you the ppWPTools I am using