Ignore soft page breaks

  • When using LayoutMode of wplayShowManualPageBreaks I would like the editor to fully pretend there is no soft page break. What happens is, if the user has an image close to a soft page break, it looks fine like there is no page break. However if they add a tab in front of the image, it does not indent the image but instead the tab gets added above the image since the image has been pushed to the next page in effect and knows the tab can fit on the previous page. This is also true if you add text in front of the image... however, in this case it adds the text to the left of the image as expected, but when you save and reload the WPRIchText the text is then above the image (again because the text will fit on the page but the image won't). So not only is the editor aware of the soft page break, it is treating tabs differently than text during editing.


    I thought the wpfIgnoreSoftPageBreaks might be the answer, but I was sure wrong on that, lol. All text after the soft page break is fully ignored and not even shown. Also looked at the wpInfiniteTextArea, but that too did not do what I was hoping for. Maybe there is a different option I'm overlooking?


    Basically what I'm looking for is a way to make the page length infinite so there are no soft page breaks at all, but only when using the wplayShowManualPageBreaks layout mode. or perhaps a new layout mode that has no soft page breaks but still shows and honors manual page breaks.


    There seems to always be something more we need, right? ;)


    Eric


    P.S. The reason for this is that they are just editing a single topic, possibly one of many appended to each other. It is just one of many topics to be added during a mail merge, so a page break in the editor can be meaningless and can confuse the customer. We do have the option to edit in Full Layout mode if they desire to see page breaks in case they are only going to have one topic or that topic will be starting on a new page, etc.

  • WPTools always creates its virtual pages when formatting the text and right now they have a certain height. Since there can be also header and footer it would also be pretty difficult to do otherwise so it actually creates those breaks.


    But why not simply make the pages really height? You can use the event OnMeasurePageHeight to do this without having to mess with the setup of the RTF page information.

  • Understood and thought about making the page height huge when using wplayShowManualPageBreaks but users can flip between that and full layout which we would then have to reset it back to the real height they set up for that topic. I guess was hoping by setting it to wplayShowManualPageBreaks that you would do something like that internally since headers/footer are not used in that layout mode and therefore why concern yourself with soft page breaks at all in that mode.


    However, if you always set up a virtual page, I guess it was just just wishful thinking on my part and I understand the complications. I'll look into toggling page height depending on layout mode.


    Thanks for the tip on OnMeasurePageHeight !

  • Cool. I did find this in your help info that took care of hiding the lines in WPT9, which WPT5 did not show by default, when using wplayShowManualPageBreaks. Adding it as a new property is better! :)

    WPRichText1.Memo._DontShowSoftPageBreak := true;