TWPSymbolDlgEx - bad display

  • With the 9.1.016 update from 2019-10-25 (and maybe earlier versions since I don't know when this started but it used to work), the WPSymbolDlgEx dialog does not display properly until you resize the dialog. Only the first row appears, but then the whole grid shows up once you start resizing the dialog.


    FWIW, the dialog could use a slight tweak... the encapsulating border and Subset dropdown right side is right on the right edge, and the buttons are right on the bottom edge. Personal preference is to have some and equal spacing around the whole dialog. ;)


    Also, everything is "relatively" huge (perhaps that is due to my use of a 4K monitor at 100% scale and you are drawing the dialog based on screen size which would be good...so just checking if that was intended).


    One other question... is there a way to have the dialog centered based on the main form or better yet, the owner form? On a 4K monitor it throws the dialog way up to the left corner.


    Eric

  • I made a few minor changes to the WPSymbolDlgEx myself, like changed the Position property to pOwnerFormCenter which does the positioning "fix" (can you make that a control property?)


    I also changed the dialog border from 0 to 5, and resized Panel1 to fit within the dialog and centered it. This "fixes" the alignment stuff I mentioned. I can send you my changes if you want. I just hope I don't need to make the sames changes on each update. :)


    I did not spend a lot of time to find out how to cleanly fix the drawing of the grid. The RowCount is set to 1 in the Panel Resize event before the IDToUnicode is initialized. I temporarily fixed it by calling PanelResize after the cbxFontListChange(Sender) call in FormActivate. Probably not the best fix but it works. ;)


    Eric