Splitting tables, spacing and cursor pos problem

  • When I split a table using WPRichText1.SplitTable, there is barely any space between the two tables, so it is hard to know they actually were split other than selecting rows/columns with the mouse. The FormatOptionsEx2.wpfAlwaysGenerateParBetweenTables option is set to true, but I do not get a par between the two tables on a split.


    After a split, the cursor is in the first cell of the 2nd table. Hitting enter does not add a paragraph spacing between the tables like it did with WPTools 5. For reference with WPTools 5 it was a bit more intuitive for adding spacing. Hitting enter right after splitting a table added a new paragraph between the two tables and moves the cursor to that new line. Somehow WP5 knew that if you hit enter in the first position of the first cell, and there is no paragraph between it and the previous table, it adds a paragraph and sets the cursor pos to that new par. Is there a new option that I can't find to make it behave like it did with WPtools 5?


    Strange cursor positioning issue with WP9 and table splitting: Create a 3 x 3 table in a WPRichText. Place the text cursor in the middle cell and split the table. The text cursor moves to the first cell of the 2nd table. Hit the cursor up key. The text cursor appears below both tables indented about an inch instead of between the two tables. Hitting the cursor up again, places the cursor in the 3rd column of the first table. Cursor down puts it once again below both tables. Hitting enter even when the cursor is below the two tables adds spacing between the two tables. If you do the same thing but first add maybe 10 lines before creating the table, hitting the cursor up key positions the text cursor on line 6, indented about an inch. No matter how many lines there are before the table, the cursor always goes to the same spot in the WPRichText.


    WPTools 9.1.016

    Delphi 10.3.2


    Eric

  • It is actually purpose that there is no distance between the tables. If you need one, you need to append a paragraph to the first table object.


    That can be done with

    Quote

    if WPRichText1.SplitTable then

    begin

    WPRichText1.Table.PrependNewPar.Text := 'Text between Tables';

    WPRichText1.ReformatAll;

    end;

    Thanks for reporting the problem with Cursor-up in the next table. That will be fixed.