Incorrect display of special characters in the PDF

  • If you use unicodes you need to use the CIDFont embedding.


    For special symbol fonts ist is better to assign there name to the Type3Font list so they are converted to glyphs.


    It is known that windows allow all kind of symbols in any text - it will select the matching font from all installed fonts. That happens intransparently and cannot be reproduced by wPDF. So only glyphs can be exported which are actually in the font file - unless you use the Type3 method.

  • Thank you for the hints.

    I tried the following settings:

    Code
    1. CidFontMode := wpCIDUnicode;
    2. FontMode := wpEmbedType3 / wpEmbedCIDFonts / wpEmbedTrueTypeFonts;


    With Type3 I have also added the fonts I use to the font list.


    Code
    1. Type3Fonts.Add('Arial');
    2. Type3Fonts.Add('Arial MT');
    3. Type3Fonts.Add('Arial Unicode MS');
    4. Type3Fonts.Add('Arial BoldMT');
    5. Type3Fonts.Add('Verdana');


    Unfortunately I haven't had any success with it.
    I see that the PDF files become relatively large with the settings. Therefore I assume that the fonts are included.

    When I look at the properties of the PDF in Acrobat Reader, I see that the encoding of the individual fonts used is always "user-defined".
    For PDFs created with other programs, "ANSI" or "Supplied" is there, for example. So I guess that's where the problem lies.

    But where can you set the encoding?


    What am I doing wrong?