WPDF4 embedded font

  • I have a situation where a letter contains bullets that are wingdings. If I create the pdf from the existing rtf, with the fontmode wpEmbedSubsetTrueType_UsedChar, the bullets are empty boxes. If I use about any other embed option, the bullets come out correct. I would like to use the UsedChar option because of the smaller resulting file size. Using WPDF2, the resulting pdf has the correct bullets with UsedChar. The WPDF2 file size is the same size as one created with wpEmbedTrueTypeFonts; so maybe that is why it is generating it correctly.

    Any thoughts?


  • Thank you! That worked for me.

    I have one other odd scenario with bullets. The rtf has a list of bulleted items. The first bulleted line is bold. The bullet for that line does not display, but the others do. The font looks to be "Symbol", so I guess the bullet would be Symbol, Bold. I have tried all kinds of combinations and manipulating the rtf, but it always results in a "blank" display when the first letter of the line following the bullet is bolded. The text itself is Arial 11.

    Any thoughts would be greatly appreciated.

    Thanks again!

  • Hi,

    It looks like I have a similar problem.

    I try to generate a PDF which contains special characters : "●●●●●"
    (That's a const : C_MyConst = '●●●●●')

    When I use the default PDF options, I get : "?????"
    (The font is : Arial)

    When I try with "wpEmbedSubsetTrueType_UsedChar" and "wpAllSymbolFontsAsGlyph", I get the "empty boxes" (like this http://www.fileformat.info/info/unicode/char/25a1/index.htm)

    I found some working options but I've no idea which is the right solution...

    Hope you can help

    Thanks for your attention,